INCIDENT NOTIFICATION: Amazon Web Services (AWS) Down: WebABA Access Impacted
Incident Report for WebABA Legacy
Resolved
UPDATE: All indications are showing this issue is resolved. If you're still experiencing issues logging into WebABA, please reach out to our dedicated Customer Care team at support@webaba.com.

Sincerely,

Your WebABA Team
Posted Dec 15, 2021 - 16:12 EST
Investigating
INCIDENT NOTIFICATION: WebABA is being impacted by a significant AWS internet connectivity issue located in the US West regions. You can monitor progress on this incident here: https://status.aws.amazon.com/.

We apologize for the inconvenience and will notify you once we have an update.

Sincerely,

Your WebABA Team
Posted Dec 15, 2021 - 11:15 EST
This incident affected: WebABA Practice Management System.